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Xsan Best Practices 
Workflows

Many post-production facilities, both large and small, need to share media when 
working with multiple editors, graphic artists, and sound designers. Attaching 
Final Cut Pro X to central shared storage, also known as a storage area network (SAN), 
can dramatically speed up post-production and enable artists to collaborate better 
under pressure. Xsan—Apple’s SAN file system—allows multiple computers to access 
shared storage over a Fibre Channel network.

This document is designed to help you determine the best way of working with 
a SAN, such as Xsan, to speed up creative work and eliminate copying files across 
networks or hand-carrying hard drives on multiuser projects.

Two common scenarios are described below.

The first scenario sets up Final Cut Pro X for multiple users who will share a single 
project and Event, with editing access limited to one user at a time. This is essentially a 
“check-in/check out” workflow—for example, two editors on day and night shifts, or an 
offline editor who hands off the rough cut to another editor in a finishing suite.

The second scenario sets up Final Cut Pro X for two workstations sharing the same 
media simultaneously. For example, one workstation might act as the media-importing 
station and as a secondary edit station. The other workstation might be used for 
editing only. In this scenario, both workstations can access and edit the same original 
imported media stored on the SAN volume.

In both scenarios, the configuration includes an Xsan system with two Final Cut Pro X 
workstations attached via Fibre Channel. In these examples, the Xsan volume is 
running and mounted on both workstations.

For more information, see “Frequently Asked Questions” at the end of this document.
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Scenario 1: Workflow for Multiple Users,  
One User Editing at a Time
This scenario sets up Final Cut Pro X for sharing a single project and Event among 
multiple users, but with only one user having access to the project at a time. This is 
essentially a “check-in/check-out” workflow. Users can import media from a camera or 
from a folder provided by the production company.

Important:  For this workflow, the Open Directory user accounts must have the 
appropriate permissions to access the media and to allow changes to the project. To 
do this, put the Open Directory users in an Open Directory group and give that group 
Read & Write permission for the SAN Location folder on the Xsan volume. For more 
information on using Open Directory to control access to media and projects, see 
“Frequently Asked Questions” at the end of this document.

First, create a storage location on the Xsan volume.

To create a storage folder on the Xsan volume

1.	 Open Final Cut Pro X on the media import/edit system (named “EDIT1” in this example).

2.	Choose File > Add SAN Location.

3.	 Navigate to the working level of the mounted Xsan volume.

4.	Click New Folder and name the folder “Music Video.”

5.	 Click Add.

The folder you created on the Xsan volume appears as a storage location in the Event 
Library and the Project Library.

Next, import media from a hard disk to the SAN location.

To import a folder of media files from a hard disk

1.	 Choose File > Import > Files.

Note:  You can also import media directly from a camera. For information on importing 
media from cameras and other file-based devices, see the ”Import from file-based 
devices” section in Final Cut Pro X Help.

2.	Navigate to and select the folder of clips.

3.	 Select “Create new Event” and name the Event “New Song.”

4.	 In the “Save to” pop-up menu, choose the SAN location (the Music Video folder created 
in the previous task).

5.	 Make sure “Copy files to Final Cut Events folder” is selected.

6.	Click Import.

The Background Tasks indicator spins as Final Cut Pro X imports the media to the SAN 
location. When the import is finished and the thumbnail images are loaded, the media 
appears in the “New Song” Event in the Event Library.

Note:  Use the Background Tasks window to see detailed import progress. To open this 
window, click the Background Tasks indicator or choose Window > Background Tasks 
(or press Command-9).

After you import media to the SAN location, create a project in the same location.

http://help.apple.com/finalcutpro/mac/10.0.3/#verd0e78ca8
http://help.apple.com/finalcutpro/mac/10.0.3/#verd0e78ca8
http://help.apple.com/finalcutpro/
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To create and save the project in the SAN location

1.	 In the Project Library, select the “Music Video” SAN location so that it is highlighted  
in blue.

2.	Choose File > New Project (or press Command-N) and name the new project  
“New Song.”

3.	 Make sure Default Event is set to “New Song,” then click OK.

This workstation can now be used to edit the music video.

To release the SAN location so that another editor can work on the project, editors 
on the EDIT1 station can simply quit Final Cut Pro, or remove the SAN location via the 
File menu.

To remove the SAN location via the File menu

1.	 In the Event Library or the Project Library, select the SAN location you want to remove 
so that it is highlighted in blue.

2.	Choose File > Remove SAN Location.

The SAN location disappears from the Event Library and the Project Library. The 
SAN location, and any Events or projects stored there, are now available to other 
Final Cut Pro users on the network.

A second editor can continue the edit where the first editor left off by adding the 
“Music Video” SAN location to another computer, as described below.

To edit the project from another computer on the network

1.	 Open Final Cut Pro X on the second edit workstation (named “EDIT2” in this example).

2.	Choose File > Add SAN Location.

3.	 Navigate to the working level of the mounted Xsan volume, select the Music Video 
folder, then click Add.

The “New Song” Event appears in the Event Library and the “New Song” project 
appears in the Project Library.

In this way, multiple Final Cut Pro users can hand off the same project for ongoing 
editorial revision.



5White Paper
Final Cut Pro X: Xsan Best Practices

Scenario 2: Workflow for Multiple Users Editing 
the Same Media Simultaneously
This scenario sets up Final Cut Pro X for two workstations to access and edit the same 
media simultaneously.

Important:  For this workflow, the Open Directory user accounts must have the 
appropriate permissions to access the media and to allow changes to the project. To 
do this, put the Open Directory users in an Open Directory group and give that group 
Read & Write permission for the SAN Location folder on the Xsan volume. For more 
information on using Open Directory to control access to media and projects, see 
“Frequently Asked Questions” at the end of this document.

Set Up the First Edit Station

To connect the first workstation (EDIT1) to the Xsan volume

1.	 Open Final Cut Pro X on the media import/edit system (named “EDIT1” in this example).

2.	Choose File > Add SAN Location.

3.	 Navigate to the working level of the mounted Xsan volume.

4.	Click New Folder and name the folder “EDIT1-Music Video.”

5.	 Click Add.

The folder you created on the Xsan volume appears as a storage location in the Event 
Library and the Project Library.

Next, import media from a hard disk to the SAN location.

To import a folder of media files from a hard disk

1.	 Choose File > Import > Files.

Note:  You can also import media directly from a camera. For information on importing 
media from cameras and other file-based devices, see the ”Import from file-based 
devices” section in Final Cut Pro X Help.

2.	Navigate to and select the folder of clips.

3.	 Select “Create new Event” and name the Event “EDIT1-New Song.”

In this example, “EDIT1” is included in the beginning of the Event name to indicate 
that the Event was created by, and is to be used by, the first workstation, EDIT1.

4.	 In the “Save to” pop-up menu, choose the SAN location (the EDIT1-Music Video folder 
created in the previous task).

5.	 Make sure “Copy files to Final Cut Events folder” is selected.

6.	Click Import.

The Background Tasks indicator spins as Final Cut Pro X imports the media to the SAN 
location. When the import is finished and the thumbnail images are loaded, the media 
appears in the “EDIT1-New Song” Event in the Event Library, ready for use.

Note:  Use the Background Tasks window to see detailed import progress. To open the 
Background Tasks window, click the Background Tasks indicator or choose Window > 
Background Tasks (or press Command-9).

After you import media to the SAN location, create a project and save it on the Xsan 
volume or on a local hard disk on your computer (in this case, the EDIT1 workstation).

http://help.apple.com/finalcutpro/mac/10.0.3/#verd0e78ca8
http://help.apple.com/finalcutpro/mac/10.0.3/#verd0e78ca8
http://help.apple.com/finalcutpro/
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To create and save the project file in the SAN location

1.	 In the Project Library, select the “EDIT1-Music Video” SAN location so that it is 
highlighted in blue.

2.	Choose File > New Project (or press Command-N) and name the new project  
“EDIT1-New Song.”

3.	 Make sure Default Event is set to “EDIT1-New Song,” then click OK.

Note:  Render files are stored with the project file.

To create and save the project file on a local hard disk

1.	 In the Project Library, select your computer’s hard disk (or another local hard disk)  
so that it is highlighted in blue.

2.	Choose File > New Project (or press Command-N) and name the new project  
“EDIT1-New Song.”

3.	 Make sure Default Event is set to “EDIT1-New Song,” then click OK.

Note:  Render files are stored with the project file.

The EDIT1 workstation can now be used to edit the music video.

Now you can set up the second workstation to use the original media (which is also 
used by the first workstation).

Set Up the Second Edit Station

To connect the second workstation (EDIT2) to the Xsan volume

1.	 Open Final Cut Pro X on the second edit workstation (named “EDIT2” in this example).

2.	Choose File > Add SAN Location.

3.	 Navigate to the working level of the mounted Xsan volume.

4.	Click New Folder and name the folder “EDIT2-Music Video.”

5.	 Click Add.

The folder you created on the Xsan volume appears as a storage location in the Event 
Library and the Project Library.

This will be the SAN location used by the second workstation.

To import media to the second workstation (without copying)
In this scenario, the Event on the second workstation references the original media 
in its current location on the Xsan volume (as opposed to creating duplicate copies 
of the media). To set this up, you import the original media without copying it to the 
new Event on the second workstation.

1.	 Make sure the “EDIT2-Music Video” SAN location is selected in the Event Library and 
choose File > Import > Files.

2.	 In the Import Files window, navigate to the location of the original imported media: 
the Original Media folder in the EDIT1-New Song folder.

The path in this example is:

Xsan Volume Name/EDIT1-Music Video/Final Cut Events/EDIT1-New Song/Original Media
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3.	 Do one of the following:

•	 To import some of the media files to the EDIT2 workstation, Command-click  
the filenames.

•	 To import all media files in the Original Media folder, select the Original Media 
folder (in the EDIT1-New Song folder).

4.	Select “Create new Event” and name the new Event “EDIT2-New Song.”

In this example, “EDIT2” is included in the beginning of the Event name to indicate 
that the Event was created by, and is to be used by, the second workstation, EDIT2.

5.	 In the “Save to” pop-up menu, choose the “EDIT2-Music Video” SAN location.

6.	Make sure the “Copy files to Final Cut Events folder” checkbox is not selected.

The EDIT2 workstation will reference the original media in its current location on the 
Xsan volume (as opposed to duplicating the media files).

7.	 Click Import.

The Background Tasks indicator spins as Final Cut Pro X creates references to the 
original media in its existing location. When the process is finished and the thumbnail 
images are loaded, the media appears in the “EDIT2-New Song” Event in the Event 
Library, ready for use.

Note:  Use the Background Tasks window to see detailed progress information. To 
open the Background Tasks window, click the Background Tasks indicator or choose 
Window > Background Tasks (or press Command-9).

After you reference the original media in the SAN location, create a project and save it 
on the Xsan volume or on a local hard disk on your computer (in this case, the  
EDIT2 workstation).

To create and save the project file in the SAN location

1.	 In the Project Library, select the “Edit2-Music Video” SAN location so that it is 
highlighted in blue.

2.	Choose File > New Project (or press Command-N) and name the new project  
“EDIT2-New Song.”

3.	 Make sure Default Event is set to “EDIT2-New Song,” then click OK.

To create and save the project file on a local hard disk

1.	 In the Project Library, select your computer’s hard disk (or another local hard disk) so 
that it is highlighted in blue.

2.	Choose File > New Project (or press Command-N) and name the new project  
“EDIT2-New Song.”

3.	 Make sure Default Event is set to “EDIT2-New Song,” then click OK.

Now both workstations in this example can edit the same media in Final Cut Pro X  
at the same time.
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Frequently Asked Questions

Do the Final Cut Events and Final Cut Projects folders have to be at the  
root level of the Xsan volume?
No. You have a lot of flexibility when you create a folder on the Xsan volume. Using 
the Add SAN Location command in Final Cut Pro X, you can select almost any folder as 
a SAN location. Although you can access SAN locations from different computers on a 
network, only one copy of Final Cut Pro X can use a folder as a SAN location at a time.

Note:  A SAN location cannot be nested within another SAN location.

For information on adding a SAN location in Final Cut Pro X, see ”Use SAN locations for 
Events and projects” in Final Cut Pro X Help.

Does editing using Final Cut Pro X Events or projects on the Xsan volume tie 
up the SAN location for use by other editors?
No, multiple Final Cut Pro X editors can access the Xsan volume at the same time. 
However, the SAN location that was used to import the original media can only be 
used by one copy of Final Cut Pro X at a time. For more information, see “Scenario 2: 
Workflow for Multiple Users Editing the Same Media Simultaneously”.

Should I make new Events and/or new folders on the Xsan volume for each 
production or client?
Because only one copy of Final Cut Pro X can mount a SAN location at a time, it’s a 
good idea to create a separate SAN location for each Event. That way, an editor can 
access one Event without preventing other editors from accessing other Events.

Can multiple Final Cut Pro X users access the same Event at the same time?
No. But you are able to access the same media at the same time by making sure that 
the “Copy files to Final Cut Events folder” checkbox is not selected when you import 
links to the media on the Xsan volume. Events are active databases that are updated 
as the editor works. Every time an editor adds a keyword or creates a favorite, the 
Event database is updated. By allowing only one user at a time to access an Event, 
Final Cut Pro X prevents users from writing data on top of one another. Keep in mind 
that the Open Directory user accounts need to have the appropriate permissions to 
access the media.

http://help.apple.com/finalcutpro/mac/10.0.3/#verdbd6b23
http://help.apple.com/finalcutpro/mac/10.0.3/#verdbd6b23
http://help.apple.com/finalcutpro/
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Do SAN locations obey Open Directory permissions?
Yes. It’s important for all users connected to the Xsan volume to have appropriate 
permissions. Work with your system administrator to ensure your users and groups 
are configured appropriately. Refer to the OS X Server documentation for more 
information on Open Directory.

How can I control access to media and projects with Open Directory permissions?
You can modify permissions on SAN Location folders containing sensitive media, 
projects, and Events to restrict access to specific Open Directory users or groups. 
Also, content can be stored on separate Xsan volumes and then Open Directory 
permissions set on the volumes to control access. Refer to the OS X Server 
documentation for more information on Open Directory. 
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