Working with Wide Color Gamut and High Dynamic Range in Final Cut Pro X

New Workflows for Editing

White Paper
December 2017
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>3</td>
</tr>
<tr>
<td>Background</td>
<td>4</td>
</tr>
<tr>
<td>Sources of Wide-Gamut HDR Video</td>
<td>6</td>
</tr>
<tr>
<td>Wide-Gamut HDR in Final Cut Pro X</td>
<td>7</td>
</tr>
<tr>
<td>Setting Up Wide-Gamut HDR in Final Cut Pro</td>
<td>8</td>
</tr>
<tr>
<td>About Changing a Project’s Color Space</td>
<td>10</td>
</tr>
<tr>
<td>About Displays and ColorSync</td>
<td>10</td>
</tr>
<tr>
<td>Monitoring a Wide-Gamut HDR Project</td>
<td>11</td>
</tr>
<tr>
<td>Limiting PQ Output Levels</td>
<td>11</td>
</tr>
<tr>
<td>Exporting a Wide-Gamut HDR Project</td>
<td>12</td>
</tr>
<tr>
<td>Delivery to Multiple Color Spaces</td>
<td>13</td>
</tr>
<tr>
<td>Creating HDR and Rec. 709 SDR Deliverables</td>
<td>13</td>
</tr>
<tr>
<td>Converting Between HLG and PQ</td>
<td>15</td>
</tr>
<tr>
<td>Preparing for Export</td>
<td>16</td>
</tr>
<tr>
<td>Key Takeaways</td>
<td>17</td>
</tr>
<tr>
<td>Conclusion</td>
<td>18</td>
</tr>
</tbody>
</table>
Introduction

In 2015, Apple began introducing devices that record and display more colors than ever before, and in 2017 the iPhone X was introduced with support for high-dynamic-range (HDR) content. Final Cut Pro 10.4 supports not only these new cameras and displays, but also new industry standards that deliver more colorful and higher-dynamic-range video content across a wide range of professional and consumer devices. This white paper discusses the concepts behind these new capabilities and describes recommended workflows.
Since the introduction of high-definition television in the 1990s, HDTV displays have been limited to a standard range of colors defined by an industry specification for HDTV broadcasts called Rec. 709 (ITU-R Recommendation BT.709). This range of colors, or color gamut, is a subset of all the colors visible to the human eye. The Rec. 709 color gamut was based on the color characteristics of cathode ray tube (CRT) displays in use around 1990. A few years later, CRT computer displays were standardized with a color space called sRGB. Because CRT computer displays had similar characteristics to CRT televisions, sRGB adopted the Rec. 709 color gamut.

The figure below shows the CIE 1976 UCS diagram, still widely referenced today, depicting all of the colors visible to the human eye, displayed here in the color delta shape. The triangle inside the color region represents the subset of colors reproducible by the Rec. 709/sRGB color gamut.
Background

For nearly two decades, computer displays, HDTV displays, HDTV video content, and most computer-based media (graphics, photos, and videos) have continued to use the Rec. 709 color gamut. They have also used a power function (sometimes referred to as gamma) that describes the mathematical relationship between image signal values and the light level (or luminance) produced by the display. Even though CRT displays have become obsolete, most flat-panel televisions and video displays continue to display images using the Rec. 709 color gamut and CRT-based gamma function because they have remained the standard for high-definition television broadcast.

More recently, however, advances in flat-panel display technologies have enabled larger palettes of colors—“wider” color gamuts—than afforded by Rec. 709, as well as much higher luminance ranges.

Displays that support wider color gamuts with a traditional luminance range are sometimes referred to as wide-gamut, standard-dynamic-range (SDR) displays. Current Mac and iOS devices support a wider-gamut SDR color space called Display P3. Display P3 uses the same color gamut as DCI P3, the standard for movie theater digital projectors, combined with a white point and gamma appropriate for typical viewing environments. The figure below shows that the Display P3 color gamut contains more colors than the Rec. 709 gamut, with notable improvements in the range of red and green areas of the color spectrum.

Displays that support both wider color gamuts and higher luminance ranges are referred to as high-dynamic-range (HDR) displays. HDR displays, such as the one on the iPhone X, can produce not only high peak luminance values, but also very low black levels, resulting in a stunning and more realistic image. In order to encode and transmit HDR images more efficiently, new mathematical transfer functions are used instead of gamma. Two popular standards are the Perceptual Quantizer (PQ) function, defined in both SMPTE ST 2084 and ITU-R Recommendation BT.2100, and Hybrid Log-Gamma (HLG), also defined in Rec. 2100.
For several years, image sensors in professional video cameras have had the ability to capture more colors and higher dynamic range than afforded by Rec. 709. These cameras use internal image processing to constrain the output color gamut and dynamic range to Rec. 709, the broadcast industry standard. More recently, a number of pro video cameras have featured “log” recording formats, which can contain both a wider range of colors than the Rec. 709 color gamut and a higher dynamic range than can be shown on SDR displays.

When you shoot video using a log format, Final Cut Pro can process the log file to convert colors for viewing in Rec. 709 or wider color gamuts, and in either SDR or HDR. Log conversion makes the flat image look less washed-out and more vibrant. Many camera manufacturers provide their own post-production log-conversion lookup tables (LUTs) designed to make their images look good for broadcast or the cinema. In many cases, Final Cut Pro automatically applies the manufacturer-specified log processing to a clip upon import as a real-time effect that can be turned on or off later at the user’s discretion.

Some video cameras, like the RED cameras, can shoot with a RAW setting that captures the camera sensor’s wider-gamut recording capability and preserves more colors than can be displayed in Rec. 709. When importing a RED file into Final Cut Pro, you can use the RED RAW plug-in (available for download at http://www.red.com/support) to adjust the color gamut on a clip-by-clip basis, convert the RAW media to a wide-gamut log format, or convert the RAW media to a wide-gamut HDR format using the PQ transfer function.

More recently, cameras from companies such as Panasonic and Sony have begun offering HDR recording modes using the HLG transfer function. HLG uses an SDR gamma curve for the lower half of the signal values and a logarithmic curve for the upper half, allowing for programs that have a higher dynamic range while being viewable on both SDR and HDR displays.
Wide-Gamut HDR in Final Cut Pro X

The Final Cut Pro color management system automatically converts video and stills to a common “working color space.” This color space, in which compositing and rendering of visual effects are performed, is chosen to produce the best results for those operations. In earlier versions of Final Cut Pro, the working color space was a linearized version of the Rec. 709 color space, which is appropriate for working with colors that are mostly inside the Rec. 709 color gamut.

With Final Cut Pro 10.3 and later, you can choose between the traditional Rec. 709 working space and a linearized version of the new, wider-gamut Rec. 2020 color space (ITU-R Recommendation BT.2020). Rec. 2020 provides a wider gamut than Display P3 and is designed to support any new displays that may be introduced in the future. Rec. 2020 is also the color gamut used in the Rec. 2100 standard for HDR video and in common HDR delivery profiles such as HDR10.
When log footage is converted to the working space, Final Cut Pro 10.3 (and earlier versions) applied tone mapping to reduce the dynamic range of the log content to a range suitable for SDR editing. Final Cut Pro 10.4 now supports a wide-gamut (Rec. 2020) HDR working space for which log footage is no longer tone mapped upon conversion. This makes the full dynamic range of the log source footage available to effects in the working space, but it requires the user to reduce the dynamic range of the footage to a specified output range using color-grading controls, custom LUTs, or the HDR Tools effect.

Setting Up Wide-Gamut HDR in Final Cut Pro

It’s easy to set a library’s working color space and a project’s output color space to HDR in Final Cut Pro. Because the working color space is determined by the library’s color-processing setting and affects all projects and media in the library, it’s a good idea to create a separate library for each job to prevent accidental color space crossover issues.

Create an HDR library

1. Create a new library, or select an existing library in the Libraries sidebar.
2. Do one of the following:
   - Choose File > Library Properties (or press Control-Command-J).
   - Click the Inspector button in the toolbar.
3. Click the Modify button at the top of the Library Properties inspector.
4. In the dialog that appears, select Wide Gamut HDR.

Selecting this option sets the working color space to linear RGB with Rec. 2020 color primaries. With this setting, the Final Cut Pro built-in camera LUTs preserve the full dynamic range of log source media when converting to the working space.
Set the output color space for a project to wide-gamut HDR

When you set the project’s color space, the project’s render files are generated in that color space, and your project is exported in that color space if the destination codec and settings support it. During playback, video and stills are converted to the project’s color space and then displayed onscreen according to the display device’s color profile.

1. In the Libraries sidebar, select the event that contains the project you want to modify, then select the project (or double-click it to open it in the timeline).

2. Do one of the following:
   - Choose Window > Project Properties (or press Command-J).
   - Click the Inspector button in the toolbar.

3. In the Project Properties inspector, click the Modify button in the top-right corner.

4. In the dialog that appears, click the Color Space pop-up menu and choose one of the Wide Gamut HDR options:
   - **Wide Gamut HDR - Rec. 2020 PQ**: Choose this option if you want to create an HDR movie with the Rec. 2020 color space and PQ transfer function (Rec. 2100 standard). This format can be used for Dolby Vision and HDR10 mastering at a later stage.
   - **Wide Gamut HDR - Rec. 2020 HLG**: Choose this option if you want to create an HDR movie with the Rec. 2020 color space and HLG transfer function (Rec. 2100 standard). This format may be favored by some broadcasters who need the program to play on both SDR and HDR televisions.

5. Click OK.

The library and project are now set for working in wide-gamut HDR.
About Changing a Project’s Color Space

After you set a library to wide-gamut HDR, any project with HD resolution or higher created in that library can be set to either Standard - Rec. 709, Wide Gamut - Rec. 2020, Wide Gamut HDR - Rec. 2020 PQ, or Wide Gamut HDR - Rec. 2020 HLG using the Modify command in the Project Properties inspector (described in step 3 above).

You can change a project’s color space setting at any point because this setting affects the final stage of the color pipeline only. However, changing a library’s color-processing setting will affect the working space and the log processing performed by the built-in camera LUT settings. This may change the look of some effects used in the project, including the Keyer and color correction effects.

About Displays and ColorSync

Final Cut Pro uses macOS ColorSync technology to match the known color space of video or stills to the color space of an Apple display, according to the display’s ICC profile. This display profile can be set in the Displays pane of System Preferences.

As long as the display profile’s color space is wide enough to accommodate the gamut of the content, image content in the SDR luminance range will be displayed accurately in the viewer. Colors outside of the display profile’s color space will appear clipped, however. In the case of HDR, values above 50.8% signal level (100 cd/m²) for PQ and 50% signal level for HLG may appear clipped in the viewer, but these values will be written properly in exported files and sent to external HDR monitors connected by Thunderbolt video output devices.

To view the full HDR signal range in the viewer without clipping, you can select the “Show HDR as raw values” checkbox in the Playback pane of the Final Cut Pro Preferences window. This setting is especially useful for making color adjustments using onscreen controls like the eyedropper in areas of the image that may otherwise appear clipped in the viewer.
Monitoring a Wide-Gamut HDR Project

Because the viewer shows only the SDR luminance range, it’s essential to use an external HDR reference display for monitoring and grading your HDR footage. Connect this display to your Mac using a Thunderbolt video output device.

Using the video output device manufacturer’s control panel, configure the device to match the settings of your project and reference display. For example, if you’re grading for Rec. 2020 PQ, configure the display and the control panel accordingly.

Limiting PQ Output Levels

When you’re grading HDR content for a PQ deliverable, bright parts of the image can often exceed the maximum supported luminance level of the color-grading monitor or the display monitor. In this case, it’s generally a good idea to apply an adjustment to the image, known as tone mapping, to limit the maximum output level of each RGB channel. There are three ways to do this:

- Apply the HDR Tools effect, which includes a PQ Output Tone Map setting that can be used to reduce the peak brightness of clips in a PQ project to a specified level. The HDR Tools effect applies a soft rolloff to the highlights so that important visual detail is not clipped.

- Use a third-party tool to create a LUT whose output is set to Rec. 2020 PQ and limited to a specified level. You can apply this LUT in Final Cut Pro using the Custom LUT effect.

- Apply a Color Curves color correction effect, with the curve shape configured to apply a soft rolloff to the bright areas of the image so that it’s within the range that can be displayed on the color-grading monitor.

When performing these adjustments, it may be helpful to show the Waveform video scope and set it to either RGB Parade or RGB Overlay view. In these views, the vertical axis of the waveform is labeled in units of cd/m² (also known as nits), which is a measure of the display’s output brightness level corresponding to the PQ signal level. Note that for the Luma and Chroma views, and for any non-PQ content, the vertical axis reverts to IRE (where 100 IRE represents 100% signal level). This is because the waveform signal in these cases does not correspond directly to absolute cd/m² values.
Exporting a Wide-Gamut HDR Project

When you’re ready to export a project as a wide-gamut HDR master, it’s usually best to use the Master File destination in the Share menu. For optimal results, use a 10-bit or higher codec such as Apple ProRes. Make sure that the “Color space” field in the Settings pane of the Master File Share window displays either Wide Gamut HDR - Rec. 2020 PQ or Wide Gamut HDR - Rec. 2020 HLG.
In some cases, you may need to deliver a single project in both Rec. 2020 HDR and Rec. 709 SDR, or you may need to deliver an HDR project in both PQ and HLG. In that case, it’s best to work in a wide-gamut HDR library so that edits, effects, and color correction are performed in the widest color gamut available. You can choose whether to create your Rec. 709 SDR project or your HDR project first. If your HDR deliverable needs to look its best and the SDR deliverable is secondary, it’s recommended that you create your HDR project first using the steps below.

Creating HDR and Rec. 709 SDR Deliverables

After you create a Rec. 2020 HDR master, you can begin working in a second master (or submaster) in the Rec. 709 color space.

Create your HDR master

1. Follow the instructions in Setting Up Wide-Gamut HDR in Final Cut Pro to create an HDR library and an HDR project (either PQ or HLG).
2. Make sure your HDR monitor and video output device are set up with the correct HDR color space settings (Rec. 2020 PQ or HLG).
3. Edit and color correct your footage.
4. Use the HDR Tools effect to do any of the following:
   - Convert HLG clips to PQ or PQ clips to HLG.
   - For PQ projects, apply a tone map that softly rolls off the output of each RGB component to a specified level of cd/m². To prevent image details from being clipped unnecessarily, make sure the specified level of brightness matches the capabilities of the monitor that will be used to play back the project.
Create your Rec. 709 SDR submaster
1. In the Final Cut Pro browser, select your master HDR project, then choose Edit > Duplicate Project as Snapshot.
2. With the duplicated project selected in the browser, choose Window > Project Properties (or press Command-J), then click the Modify button in the top-right corner of the inspector.
3. In the dialog that appears, click the Color Space pop-up menu and choose Standard - Rec. 709.
4. In the browser, click the name of the duplicated project (the submaster), then type “Rec. 709” at the end of the name.
5. In the browser, click the name of the original project (the master), type “HDR” (or other identifying label) at the end of the name, then press Return.

Perform a trim pass in the Rec. 709 project
To ensure that the Rec. 2020 master and Rec. 709 submaster look similar, you can perform a trim pass color adjustment on the Rec. 709 project to bring all the colors in line with broadcast specifications. When performing a trim pass in a Rec. 709 project, try to match the look and feel of the Rec. 2020 project as closely as possible.
1. If you’re using an external display, set it and the connected video output device to the Rec. 709 color space.
2. Remove any instances of the HDR Tools effect that have the Mode pop-up menu set to PQ Output Tone Map.
   You can select all the video clips in the SDR project and use the Remove Attributes command to delete only the HDR Tools effect.
3. Apply the HDR Tools effect, then, in the HDR Tools section of the Video inspector, click the Mode pop-up menu and choose HDR to Rec. 709 SDR.
   If you have your own 3D LUT file that converts from HDR to Rec. 709 SDR, you can apply it with the Custom LUT effect, using one of these methods:
   • Apply the effect to individual HDR clips in the timeline. (You can use the Paste Attributes command to copy the effect to other clips.)
   • Select all clips in the timeline and create a compound clip, then apply the effect to the compound clip.
   • Create a blank Motion Template title effect, connect it to the timeline on top of all the original media, then apply the HDR Tools or Custom LUT effect to the connected title.
4. Apply Color Curves and Color Wheels color correction effects as needed to achieve the look you want.
Converting Between HLG and PQ

If you know the peak brightness of your target display, you can convert a Rec. 2020 HLG clip to Rec. 2020 PQ and vice versa, in accordance with the Rec. 2100 standard. This method ensures that the appearance of your HLG clip on an HLG display matches the appearance of your PQ clip on a PQ display.

Convert a single clip

1. Make sure your library is set to Wide Gamut HDR color processing. For instructions, see Setting Up Wide-Gamut HDR in Final Cut Pro.
2. Add your HDR clip to the project’s timeline.
3. With the project selected in the browser, choose Window > Project Properties (or press Command-J), then click the Modify button in the top-right corner of the inspector.
4. In the dialog that appears, click the Color Space pop-up menu and choose the output color space you want to convert to.
   For example, if you’re converting to Rec. 2020 PQ, choose Wide Gamut HDR - Rec. 2020 PQ.
5. Apply the HDR Tools effect to your clip in the timeline, and select the clip.
6. In the HDR Tools section of the Video inspector, click the Mode pop-up menu and choose one of the following:
   • **HLG to PQ (Rec. 2100):** Converts from HLG to PQ.
   • **PQ to HLG (Rec. 2100):** Converts from PQ to HLG.
7. Adjust the Peak Brightness slider according to the capabilities of the monitor you plan to use to display the project.
   By default, Peak Brightness should be set to 1000 cd/m².
Convert an entire project

1. In the Final Cut Pro browser, select your project, then choose Edit > Duplicate Project as Snapshot.

2. With the duplicated project selected in the browser, choose Window > Project Properties (or press Command-J), then click the Modify button in the top-right corner of the inspector.

3. In the dialog that appears, click the Color Space pop-up menu and choose the output color space you want to convert to.
   For example, if you’re converting to Rec. 2020 PQ, choose Wide Gamut HDR - Rec. 2020 PQ.

4. Select all the clips in the timeline and create a compound clip.

5. Apply the HDR Tools effect to the compound clip, then select it in the timeline.

6. In the HDR Tools section of the Video inspector, click the Mode pop-up menu and choose one of the following:
   • *HLG to PQ (Rec. 2100):* Converts from HLG to PQ.
   • *PQ to HLG (Rec. 2100):* Converts from PQ to HLG.

7. Adjust the Peak Brightness slider according to the capabilities of the monitor you plan to use to display the project.
   By default, Peak Brightness should be set to 1000 cd/m².

Preparing for Export

Not all share settings support wide-gamut HDR. To ensure that the colors within your timeline are maintained in the exported master file, choose a share option that supports the color space of your project. Using the Master File destination with Apple ProRes 422 HQ, Apple ProRes 4444, or Apple ProRes 4444 XQ is generally the best way to export a wide-gamut HDR file from Final Cut Pro.

To ensure that your share destination supports HDR, always check the “Color space” field in the Settings pane of the Share window before you export. Warning text appears in the Settings pane if the share destination does not support HDR.
Key Takeaways

Here are some basic principles to keep in mind when working with wide-gamut HDR:

• Begin work in a library set to Wide Gamut HDR color processing and a project that has also been set to HDR (either PQ or HLG).

• Use an external HDR display connected through a Thunderbolt video output device to grade and monitor HDR content.

• If you need to edit log or HDR content in a Rec. 709 SDR project, you may need to apply an effect to reduce the dynamic range of the content. You can do this using the HDR Tools effect, a Custom LUT effect, or a Color Curves color correction effect.

• Deliver your final project in a codec that supports the color space of your project. For wide-gamut HDR, Apple ProRes is recommended.
Conclusion

Shooting, editing, and delivering video with a wider color gamut and higher dynamic range is a great way to create projects that can be repurposed for many years. You’ll be able to return to the higher-quality master file for different delivery options. In the future, more broadcasters and websites will support transmission or streaming of wide-gamut HDR programming, and more televisions and mobile devices will support the display of wide-gamut HDR video. With a catalogue of material that stands out as visually distinctive, you’ll be well positioned to take advantage of the emerging technology changes in the film and video industries.